« おぼろづき | トップページ | RD-XS43をバージョンアップ »

2008年10月11日

LightBoxが利用不可に

ココログのメンテナンスで、IEでLightBoxが使えなくなってしまったようだ。
強制的に、mootoolsやらMultiboxが組み込まれるようになってしまったかららしい。
仕方がないので、互換があるSlimboxを導入してみました。
今日現在、ココログで使われているmootoolsのバージョンが1.11系みたいなので、Slimbox 1.53を導入してみました。Slimbox 1.64だとエラーになるようです。
”/css”フォルダ全部と、”/js”フォルダの”slimbox.js”だけを導入します。
mootoolsは、ココログが自動的に導入するので、それを活用します。

入れ替えてスクリプトを書き換えます。

<script type="text/javascript" src="http://akihitof.cocolog-nifty.com/js/slimbox.js"></script>
<link rel="stylesheet" href="http://akihitof.cocolog-nifty.com/css/slimbox.css" type="text/css">

これだけで、互換があるのでポップアップが復活しました。
使いもしないスクリプトを勝手に埋め込まないで欲しいなぁ。

ーーー追記ーーー
Slimboxも最新の(ベータ版)Windows Live Writerに対応しているようで、グループ設定を簡単に設定できるみたいです。これはこれで嬉しいかも。

|

« おぼろづき | トップページ | RD-XS43をバージョンアップ »

コメント

初めまして。
コチラの記事を読んでSlimboxを導入したのですが、上手く動作しません。

現在はココログプロを利用しています。
「Archive Index Template」「Main Index Template」「Category Archives」「DateBased Archives」「Individual Archives」に記載してあります。

何か根本的な間違いをしているのでしょうか?
具体的な導入の方法をお教え願えませんでしょうか?

投稿: Sleepy | 2008年11月 3日 午前 01時13分

ココログプロの設定は分かりません。
ココログプロは、すでにSlimbox(かな)が導入されているはずですので、サポートを利用するほうがよいのではないでしょうか。
http://support.cocolog-nifty.com/tsushin/2008/09/post-7363.html
Firefoxだと"エラーコンソール"などで動作を確認できますので、そういうツールで確認してみてはどうでしょう。
普通のJava Scriptと導入方法は同じです。
当然、Mootools.jsが読み込まれているかも確認してください。

投稿: ふるかわあきひと | 2008年11月 5日 午後 10時40分

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/2700/42752336

この記事へのトラックバック一覧です: LightBoxが利用不可に:

« おぼろづき | トップページ | RD-XS43をバージョンアップ »